https://github.com/osquery/osquery logo
#fleet
Title
# fleet
m

Mike S.

05/01/2023, 10:10 PM
Hi team - I saw some comments on this but wanted to confirm - are Fleet packages available for 32-bit systems? Specifically we're looking at older Windows systems.
z

Zay Hanlon

05/01/2023, 11:02 PM
Hi @Mike S. Are you deploying fleetd (Orbit) or a plain osquery agent?
"Windows, macOS, CentOS, and almost every Linux OS released since 2011 are supported with no dependencies."
Also found this old issue that says Win 7 32-bit support would 'take some time' back in 2017: https://github.com/osquery/osquery/issues/3258
m

Mike S.

05/02/2023, 3:08 PM
Hi @Zay Hanlon - Ideally we'd want to deploy an Orbit client.
z

Zay Hanlon

05/02/2023, 6:19 PM
@Mike S. So I have the official verdict. Osquery doesn't build or publish packages for 32 bit systems, so Fleet does not support there. Sorry!
m

Mike S.

05/02/2023, 7:27 PM
Not a problem, I appreciate the official response! 🙂
z

Zay Hanlon

05/02/2023, 8:44 PM
Sure thing!
2 Views