Hi all :wave: I’m setting up a fleet instance on <...
# fleet
s
Hi all 👋 I’m setting up a fleet instance on fly.io but running into issues with fleet’s connection to my redis server:
Copy code
Failed to start: initialize Redis: refresh cluster: redisc: all nodes failed
dial tcp: address <redis://default>:***@fly-wealthbit-fleet-redis.upstash.io:6379: too many colons in address
The value of the env var
FLEET_REDIS_ADDRESS=<redis://default>:***@fly-wealthbit-fleet-redis.upstash.io:6379
(note the trailing colon is added by the logger only, and * is replaced with the password). From my searches it seems this is an issue with Go parsing the URL, I think it’s expecting just a host and port like
fly-wealthbit-fleet-redis.upstash.io:6379
but when I try this I get a
NOAUTH Authentication required
error of course. Is there a different way I can specify the credentials of my redis server?
Looking at where
FLEET_REDIS_ADDRESS
occurs in the fleet codebase it seems it does just need a host and port… so does that mean it needs a redis instance that doesn’t require a username and password / or uses the default redis username / password?
g
Hey @Simon van Dyk, Believe there are environment variables for Redis username and password. Also welcome to apply config with
fleetctl apply
.
s
Thanks @Grant Bilstad, great docs! Once/If I get it up I’ll share my fly configuration in case you want it.
@Grant Bilstad That did the trick, I’m up and running and got my first host registered. I’ve extracted this config if you folks want to use it.