Simon van Dyk
12/12/2023, 6:45 PMFailed to start: initialize Redis: refresh cluster: redisc: all nodes failed
dial tcp: address <redis://default>:***@fly-wealthbit-fleet-redis.upstash.io:6379: too many colons in address
The value of the env var FLEET_REDIS_ADDRESS=<redis://default>:***@fly-wealthbit-fleet-redis.upstash.io:6379 (note the trailing colon is added by the logger only, and * is replaced with the password).
From my searches it seems this is an issue with Go parsing the URL, I think it’s expecting just a host and port like fly-wealthbit-fleet-redis.upstash.io:6379 but when I try this I get a NOAUTH Authentication required error of course.
Is there a different way I can specify the credentials of my redis server?Simon van Dyk
12/12/2023, 6:59 PMFLEET_REDIS_ADDRESS occurs in the fleet codebase it seems it does just need a host and port… so does that mean it needs a redis instance that doesn’t require a username and password / or uses the default redis username / password?Grant Bilstad
12/12/2023, 11:28 PMfleetctl apply.Simon van Dyk
12/13/2023, 10:04 AMSimon van Dyk
12/13/2023, 12:09 PM