Title
#macos
CptOfEvilMinions

CptOfEvilMinions

01/24/2022, 8:20 PM
Anyone else receiving the following error with macos osquery
magic
table:
osquery> select * from magic WHERE path like '/usr/local/bin/%';
W0124 14:19:17.487205 337212928 magic.cpp:53] Unable to load magic list of database: /usr/share/file/magic.mgc:/usr/share/misc/magic.mgc because: File 5.32 supports only version 14 magic files. `/usr/share/file/magic.mgc' is version 16
osquery>
osquery> .version
osquery 5.0.1
using SQLite 3.35.5
osquery>
osquery> select * from os_version;
         name = macOS
      version = 12.1
     platform = darwin
         arch = x86_64
osquery>
Stefano Bonicatti

Stefano Bonicatti

01/24/2022, 8:54 PM
osquery 5.2.1 will use libmagic 5.40
8:54 PM
so that shouldn’t be a problem anymore
CptOfEvilMinions

CptOfEvilMinions

01/24/2022, 9:15 PM
@Stefano Bonicatti should I close my github issue?