Title
#kolide
m

MarkMurdock

10/19/2021, 9:54 PM
Hi, I've built launcher/package-builder on Windows, but when I attempt to create a Windows service MSI package with package-builder, I'm getting the following error:
C:\Go\src\<http://github.com|github.com>\kolide\launcher\build>..\build\package-builder make --hostname=<http://uscolo1fleet01.corp.dir.spartech.com:8080|uscolo1fleet01.corp.dir.spartech.com:8080> --enroll_secret=RYQ2Q8knFcFzH1J/LHyEnqZkRbb+x3Ah
could not generate packages: making package: packaging, target windows-service-msi: getting asset kolide.ico: open kolide.ico: file does not exist
s

seph

10/20/2021, 4:52 AM
I recently changed something in the asset bundling. I’ll try to take a look tomorrow
m

MarkMurdock

10/20/2021, 4:05 PM
Ok thank you!
2:51 PM
Just checking in to see if you found anything? It could be something I'm doing wrong too.
s

seph

10/25/2021, 2:51 PM
Thanks for checking in. I haven’t had a change to pick it up. Question for you though… Are you using HEAD or the last released version?
m

MarkMurdock

10/26/2021, 7:28 PM
I cloned the code with: git clone https://github.com/kolide/launcher.git
7:28 PM
So I may need your help telling me which I obtained.
s

seph

10/26/2021, 7:29 PM
Yes, that’s HEAD. Do you have the error working off the last release? Either download it from https://github.com/kolide/launcher/releases/tag/v0.11.22 or checkout the
v0.11.22
tag
7:30 PM
The
windows.amd64_v0.11.22
file includes a
package-builder.exe
m

MarkMurdock

10/26/2021, 8:04 PM
Ok I'll give that a try and see what I get
8:04 PM
thanks!
6:56 PM
Yes the package-builder.exe from v0.11.22 worked fine. My takeaway from this is I should probably use the latest release instead of trying to clone from HEAD and compile.
s

seph

10/27/2021, 8:47 PM
I try to keep HEAD working. I broke it recently and need to fix it — this represents a gap in test coverage
3:42 PM
I've merged a fix for this. And tests as well. Thank you for bringing it up!