Title
#general
Tim

Tim

07/09/2020, 3:56 PM
Has anyone attempted to build osquery for aarch64? I'm running into this error during the build step
[  7%] Building C object libs/src/boost/CMakeFiles/thirdparty_boost_context.dir/src/libs/context/src/asm/jump_arm64_aapcs_elf_gas.S.o
/home/ec2-user/osquery/libraries/cmake/source/boost/src/libs/context/src/asm/jump_arm64_aapcs_elf_gas.S:54:1: error: expected identifier or '('
.file "jump_arm64_aapcs_elf_gas.S"
^
/home/ec2-user/osquery/libraries/cmake/source/boost/src/libs/context/src/asm/jump_arm64_aapcs_elf_gas.S:60:7: error: invalid preprocessing directive
    # prepare stack for GP + FPU
      ^
/home/ec2-user/osquery/libraries/cmake/source/boost/src/libs/context/src/asm/jump_arm64_aapcs_elf_gas.S:63:7: error: invalid preprocessing directive
    # save d8 - d15
      ^
theopolis

theopolis

07/09/2020, 6:57 PM
There are a few related issues and PRs for ARM64, check out https://github.com/osquery/osquery/tree/aarch64-support