Saulo Guilhermino
06/08/2026, 2:58 PMv4.86.0, is breaking for Kubernetes deployments that use a mandatory read-only file system. It's necessary to create a volume (usually an emptyDir) in /tmp/org-logos so that the application doesn't get stuck in CrashLoopBackOff with the log below:
Using config file: /tmp/config/fleet.yaml
{"ts":"2026-06-08T14:33:30Z","level":"info","msg":"redis initialized","component":"redis","mode":1}
{"ts":"2026-06-08T14:33:30Z","level":"info","msg":"host lookup redis cache enabled","component":"mysqlredis","ttl":60000000000}
Failed to start: initializing filesystem org logo store: mkdir /tmp/org-logos: read-only file systemGray Williams
06/08/2026, 3:01 PMGray Williams
06/08/2026, 3:18 PMGray Williams
06/08/2026, 3:52 PMLuke Heath
06/08/2026, 4:59 PMGray Williams
06/15/2026, 11:03 AMSaulo Guilhermino
06/15/2026, 2:17 PM