Title
#general
t

Tom Ritter

11/25/2019, 4:57 PM
So ossfuzz build is broken, because sometime recently osquery started requiring python 3.6 and up, which isn't in xenial by default. Is there a way to get 3.6 in xenial that doesn't involve "Just use this random person's ppa"? (Or is there a random person we might trust? Level of trust doesn't have to be super-high I don't think....)
k

Kuzma Fesenko

11/25/2019, 5:10 PM
According to this Stack Exchange post in askubuntu, the random ppas are the best option, or you could use pyenv: https://askubuntu.com/a/865644
5:11 PM
But I would trust the PPA's mentioned, since it's the accepted answer with lots of votes.
g

groob

11/25/2019, 5:18 PM
16.04 is not EOL yet?
s

seph

11/25/2019, 5:21 PM
16.04 ended “standard support”. Full EoL is April 2024.
g

groob

11/25/2019, 5:21 PM
and they’re committed to py2 until then?
t

Tom Ritter

11/25/2019, 5:21 PM
They have 3, it's just 3.5
g

groob

11/25/2019, 5:22 PM
ah!
t

Tom Ritter

11/25/2019, 5:22 PM
I don't know if they have plans for an upgrade....
5:22 PM
Nor do I know if oss-fuzz has plans to upgrade their base image
s

seph

11/25/2019, 5:23 PM
I wonder if it’s easy to move to python35
t

Tom Ritter

11/25/2019, 5:24 PM
https://github.com/osquery/osquery/pull/6057 - I have no context about why 3.5 is excluded from the search list
5:24 PM
But I can tell you that before this patch, at least one configuration of osquery built fine with 3.5 🙂
g

groob

11/25/2019, 5:24 PM
can you file an issue?
s

seph

11/25/2019, 5:25 PM
Probably oversight. There’s a comment for python38 support too
Stefano Bonicatti

Stefano Bonicatti

11/25/2019, 5:27 PM
Yeah partially an oversight (thought 3.5 was already EOL) and because those are the python versions we have tested the various python scripts we have.