Title
#fleet
r

ryan

01/25/2022, 4:57 PM
Question about generating an installer package for Mac OS. I keep getting
root pinning is not supported in Spec 1.0.19
when I generate a package and couldn't find anything in this channel about resolving it. Any tips? Running fleetctl 4.9 on MAC OS and using
fleetctl package --type=pkg --fleet-url=xxx --enroll-secret=xxx
koo

koo

01/25/2022, 5:04 PM
Hey Ryan. The message is more of a warning than an error. That said, this issue is known and would probably be resolved sooner than later.
zwass

zwass

01/25/2022, 5:23 PM
Tracked in https://github.com/fleetdm/fleet/issues/3699. The warning is very noisy but should not have negative effects on the security of the system (because it's essentially warning about redundant metadata).
r

ryan

01/25/2022, 6:08 PM
Sorry I should have mentioned it was showing up in client logs to. Sounds good - thx 👍