Title
#fleet
s

Silvano Ngacha

08/02/2021, 9:40 AM
fleetctl login
is throwing an error:
Login failed: POST /api/v1/fleet/login: Post "<https://localhost:8080/api/v1/fleet/login>": x509: certificate is not valid for any names, but wanted to match localhost
a

Avi Norowitz

08/02/2021, 1:01 PM
If you point fleetctl to localhost, I believe you need to use
--tls-skip-verify
. See: https://github.com/fleetdm/fleet/blob/main/docs/1-Using-Fleet/2-fleetctl-CLI.md
1:03 PM
But don't use this flag in production if you have Fleet running on a remote machine.
Mystery Incorporated

Mystery Incorporated

08/02/2021, 2:01 PM
Instead of using localhost, use the URL of your fleet server because the certificate is for the URL. Of course you will have to do the skip verify Avi mentions if you do not trust the CA certificate for your fleet server cert on that machine. Error is you are accessing "localhost" but certificate is issued to "yourdomain.xyz".
s

Silvano Ngacha

08/03/2021, 6:44 AM
Got it. Thanks @Avi Norowitz and @Mystery Incorporated It is now working.