Title
#fleet
w

Willi

04/26/2021, 2:53 PM
Hi, i tried to build osquery .msi-installer with "orbit" and encountered the following error:
[13:25 Uhr] heat.exe : error HEAT0001 : Access to the path 'Z:\wix\root\bin\orbit\windows\stable' is denied.
Does someone know how to change the WIX build path?
zwass

zwass

04/26/2021, 3:36 PM
Which platform are you building from? Are you running as the root user? I wonder if you are having issues with the permissions of the generated files because the Wix container is running as non-root.
w

Willi

04/26/2021, 4:07 PM
I tried to build direct on windows (this is where the error comes from ) and on ubuntu (where i had exec format error). I made sure that I am the root user in both cases. On windows wix is already installed and tested, but I dont know how/if orbit determines the build location, because Z-drive does not exists on my system.
zwass

zwass

04/26/2021, 5:53 PM
Can you provide the error you are getting with Linux? This package build not yet been tested using Windows as the host, so there may be some different permissions considerations we need to take into account.
w

Willi

04/27/2021, 9:02 AM
I dowloaded the orbit repo, went inside and executed:
go run ./cmd/package --type msi --fleet-url=<my_url>:<my_port> --enroll-secret=<mysecret>
then I recived:
FTL package failed error="initialize updates: failed to get osqueryd: exec new version: : fork/exec /tmp/orbit-package810493282/root/staging/osqueryd.exe: exec format error"
exit status 1
zwass

zwass

04/27/2021, 3:45 PM
Can you update to the lastest version of
main
and try again? Let me know if you still see that issue.
w

Willi

04/28/2021, 1:06 PM
I did not work, i recieved the same error