Title
#kolide
a

asparamancer

08/13/2019, 4:25 PM
how do I specify the redis address for launcher? It's currently trying to go to an internal ip:53 - pretty sure it's exposed on fleet-cache-redis:6379
zwass

zwass

08/13/2019, 4:27 PM
Are you talking about Fleet? Launcher does not make any Redis connections.
a

asparamancer

08/13/2019, 4:30 PM
yes sorry, I'm getting the following when I send a query down from kolide,
PUBLISH failed to channel results_2: dial tcp: lookup fleet-cache-redis on 10.0.0.10:53: no such host","errcode"
a

asparamancer

08/13/2019, 4:33 PM
zwass

zwass

08/13/2019, 4:34 PM
Cool, configuring that value ought to fix it for ya.
a

asparamancer

08/13/2019, 4:34 PM
which value sorry?
zwass

zwass

08/13/2019, 4:35 PM
redis_address
a

asparamancer

08/13/2019, 4:36 PM
thanks, but shouldn't it pick it up from the service which
helm install \
  --name fleet-cache \
  --set persistence.enabled=false \
  stable/redis
sets up exposing it on fleet-cache-redis:6379?
s

seph

08/13/2019, 4:37 PM
:53 is a dns port. I wonder if somethjing else is amiss?
zwass

zwass

08/13/2019, 4:38 PM
You're showing a command for installing Redis. Did you configure fleet with the appropriate address for Redis?
g

groob

08/13/2019, 4:39 PM
you’re also several layers of abstraction above fleet itself (helm, kubernetes) Make sure you understand these components well
a

asparamancer

08/13/2019, 4:43 PM
been a numpty, exposed it on the service fleet-cache-redis-master:6379 ...
4:43 PM
thanks for the help all