Title
#kolide
harveywells

harveywells

08/12/2019, 9:24 PM
Howdy gang. I generated a self signed cert to play with in dev for some potential changes to our Kolide Fleet server architecture. The Fleet container starts up and will eventually exit after a few seconds. I see the following in the logs:
fleet-jwzm docker[1426]: ################################################################################
Aug 12 20:31:57 fleet-test docker[1426]: # WARNING:
Aug 12 20:31:57 fleet-test docker[1426]: #   Your Fleet database is missing required migrations. This is likely to cause
Aug 12 20:31:57 fleet-test docker[1426]: #   errors in Fleet.
Aug 12 20:31:57 fleet-test docker[1426]: #
Aug 12 20:31:57 fleet-test docker[1426]: #   Run `/usr/bin/fleet prepare db` to perform migrations.
Aug 12 20:31:57fleet-test docker[1426]: ################################################################################
Aug 12 20:31:57 fleet-test docker[1426]: ts=2019-08-12T20:31:57.228583618Z component=service method=ListUsers user=none err=null took=1.743137ms
Aug 12 20:31:57fleet-test docker[1426]: ts=2019-08-12T20:31:57.230041875Z transport=https address=0.0.0.0:8080 msg=listening
Aug 12 20:31:57 fleet-test docker[1426]: ts=2019-08-12T20:31:57.230436248Z terminated="tls: failed to find any PEM data in certificate input"
A self signed cert wouldn’t be an issue here?
zwass

zwass

08/12/2019, 9:29 PM
Self signed certs work fine. Can you verify this cert in another tool?
harveywells

harveywells

08/13/2019, 7:34 PM
Completely my fault. I wasn’t passing the key and cert values to the Fleet container properly.
7:35 PM
It’s up and running now. Thanks for chiming in @zwass.