Title
#kolide
d

Dave Greene

02/07/2019, 1:52 PM
Hi all, I’m having 2 issues I was hoping someone could help with. The first is that I’m using a letsencrypt cert on my fleet setup but if I run the launcher without the
--insecure
flag I get
x509: certificate signed by unknown authority
. The letsencrypt root cert has explicit trust in my keychain so I’m not sure why I’m seeing this error. The second issue is that when I try to target any other platform with the package-builder I get the following error:
could not generate packages: version detection: Failed to exec. Perhaps -- Can't autodetect while cross compiling. (): run command /var/folders/0l/2f0_fh4905l8n9vsf56g08gh2c9r19/T/package.packageRoot626913343/usr/local/launcher/bin/launcher [-version], stderr=: fork/exec /var/folders/0l/2f0_fh4905l8n9vsf56g08gh2c9r19/T/package.packageRoot626913343/usr/local/launcher/bin/launcher: exec format error
The command I’m running is:
./build/package-builder make --hostname=<http://fleet.example.com|fleet.example.com> --enroll_secret=mysecret --extension_version nightly --output_dir=./build/pkg --targets=linux-systemd-deb
s

seph

02/08/2019, 1:53 PM
Package builder can’t detect what version of launcher it’s packaging. Add an appropriate
--package_version
flag
d

Dave Greene

02/08/2019, 5:48 PM
On to the next issue. Is there a way to control which directory the package builder has docker mount into the container? Docker for mac forces you to explicitly share directories and I’d rather not whitelist
/var/folders
. I tried using the
-cache_dir
flag but that seems to be only where the osquery and launcher binaries are cached.
d

Dave Greene

02/08/2019, 7:15 PM
:mind_blown:
7:16 PM
Thank you so much @seph!