Title
#kolide
m

Marc

01/22/2019, 4:39 AM
I'm getting an error when I run make deps. It's looking for deps-go directory. I have my GOPATH pointed at the ./././launcher. I have version GO 1.11. However cat of the go.mod shows pkg/error v.0.8.1
InfosecGuruji

InfosecGuruji

01/22/2019, 2:13 PM
Your GOPATH should be
/home/<user>/go
m

Marc

01/24/2019, 5:28 AM
Oh ok. Cool. Lemme give that a shot then
9:14 PM
Ok. I must be really big idiot. Set GOPATH as told. Then, I cloned once I was cd into $GOPATH... Then, I went into launcher folder inside ~/go and ran make deps. I get error: The program 'make' can be found in the following packages: ... Try: sudo apt install <select package>
9:15 PM
I can install fleet on top of this since I don't have it.
9:15 PM
Did notice I need osqueryd installed on Machine. Im going try that
9:16 PM
I'm really not sure I get these instructions since I start on the top then work down.
9:16 PM
I see comments that maybe should have in the dependency section of build from src for launcher.
9:17 PM
I'm happy to follow recommended troubleshooting procedures. I seem to be either really stupid not sure your instructions make sense.