Title
#kolide
g

groob

04/25/2018, 5:39 PM
--mysql_max_idle_conns int                    Env: KOLIDE_MYSQL_MAX_IDLE_CONNS
		MySQL maximum idle connection handles. (default 50)
      --mysql_max_open_conns int                    Env: KOLIDE_MYSQL_MAX_OPEN_CONNS
		MySQL maximum open connection handles. (default 50)
read up on your mysql config and set these values appropriately
pirxthepilot

pirxthepilot

04/25/2018, 6:08 PM
Are these options for mysql itself, or for fleet? On our server I see 50 current connections on mysql (bare metal host), but
max_connections
is actually 151.
g

groob

04/25/2018, 6:11 PM
fleet
6:11 PM
this is from
fleet serve -h
pirxthepilot

pirxthepilot

04/25/2018, 6:13 PM
6:16 PM
i guess the yaml equivalent will be
mysql:
  max_idle_conns:
  max_open_conns:
g

groob

04/25/2018, 6:18 PM
i think so. you can check through config dump
6:19 PM
yup
6:19 PM
victor@kl ~/g/s/g/k/fleet> ./build/fleet config_dump
mysql:
  address: localhost:3306
  username: kolide
  password: kolide
  database: kolide
  tls_cert: ""
  tls_key: ""
  tls_ca: ""
  tls_server_name: ""
  tls_config: ""
  max_open_conns: 50
  max_idle_conns: 50
pirxthepilot

pirxthepilot

04/25/2018, 6:28 PM
confirmed. seeing 100 connections now. thanks 🙂
g

groob

04/25/2018, 6:28 PM
were you having performance issues?
pirxthepilot

pirxthepilot

04/25/2018, 6:31 PM
not really, just wanted to test the option. though i think i'll keep it at 100 as default.