Title
#windows
f

fritz

08/28/2020, 11:45 PM
@Seth Hanford If you tell me the exact DB you are trying to configure I am happy to help more but at the base level you are right \'s need to be escaped by doing a double
\\
like the example below:
"path": "C:\\Users\\%\\AppData\\Local\\Google\\Chrome\\User Data\\Default\\databases\\chrome-extension_foo\\%"
Seth Hanford

Seth Hanford

08/29/2020, 11:14 AM
apiVersion: v1
kind: options
spec:
  overrides:
    platforms:
      windows:
        auto_table_construction:
          chrome_browser_history:
            path: C:\Users\%\Local\AppData\Google\Chrome\User Data\%\History
            columns:
              - id
              - url
              - title
              - visit_count
              - typed_count
              - last_visit_time
              - hidden
              - visit_time
              - visit_duration
              - source
            query: ...
f

fritz

08/29/2020, 1:33 PM
@Seth Hanford it has been a few months since i played around in fleetctl, if you use double
\\
in your config block does it work?
apiVersion: v1
kind: options
spec:
  overrides:
    platforms:
      windows:
        auto_table_construction:
          chrome_browser_history:
            path: C:\\Users\\%\\Local\\AppData\\Google\\Chrome\\User Data\\%\\History
            columns:
              - id
              - url
              - title
              - visit_count
              - typed_count
              - last_visit_time
              - hidden
              - visit_time
              - visit_duration
              - source
            query: ...
Seth Hanford

Seth Hanford

08/30/2020, 5:58 PM
Apologies, it was a mistake on my part. The single \ works along the path. But I mis-transcribed the path as it is Users%\AppData\Local and not the other way round as I’d typed it.
f

fritz

08/31/2020, 12:35 PM
Ah good to know! Glad you managed to catch the issue!