Title
#windows
j

Jean M

03/24/2020, 7:03 PM
(this is v4.1.2…I’ll try with the latest 4.2.0)
7:21 PM
it seems that the problem was using --
flagfile="c:\program files\osquery\osquery.pid"
with the double quotes. Without the double quotes it works:
flagfile=c:\program files\osquery\osquery.pid
sundsta

sundsta

03/24/2020, 7:24 PM
You’re also pointing the flag file to a PID file, which may cause issues
j

Jean M

03/24/2020, 9:53 PM
sorry, I mistyped, I meant pidfile! 🙂 ..and also happened to other parameters that get a file path like database_path, enroll_secret_path, etc.
11:41 PM
This is actually documented in installation/cli-flags/#flagfile 😅
NOTICE: Flags in a
flagfile
should not be wrapped in quotes, shell-macro/variable expansion is not applied!