Title
#windows
thor

thor

07/18/2019, 9:17 PM
@Tarun Chinmai Sekar is Python2 accessible via the system path? And inside of the tools/buckconfigs/windows/toolchains/vs.. configuration file, is the Python3 path set correctly?
t

Tarun Chinmai Sekar

07/19/2019, 4:33 PM
I have verified both, and Python3 Is set correctly in the config, and python2 is accessible via the system path
4:34 PM
I have also set the paths to the VCTools and Windows SDKs correctly and the config is generated properly now
4:49 PM
I noticed that buck creates folders with names like - "buck-out/release" (with the quotes). Window's doesn't like quotes in the folder names. Is this the reason?
4:54 PM
I removed the quotes in the buck-out parameter in the files - \tools\buckconfigs\windows_x86-64\type\release.cfg and debug.cfg and that solves this particular issue. Should I send a PR ?
thor

thor

07/19/2019, 5:26 PM
Did that fix it? The quotes were placed there as there's the chance of there being spaces in the path name, in which case you'll probably need quotes. You can feel free to throw it up as a PR and I can take a look.
t

Tarun Chinmai Sekar

07/19/2019, 5:36 PM
That fixed the InvalidPathException
5:37 PM
I ran into another issue with python that i've posted below in the channel
5:38 PM
and btw - The current Master has the quotes removed. I suppose someone ran into this issue and fixed it in the master. Since I'm on 3.4.0, I ran into this.