I am with another problem. LOL. sorry. From the se...
# fleet
I am with another problem. LOL. sorry. From the server I am seeing this error. I do not understand what the problem is if the token is given to me by the page and it is the one that I am putting to generate the installer.
2023/01/18 15:16:59  http: TLS handshake error from local error: tls: bad record MAC
No need to apologize! That error points to an issue with your certificate. Are you using a self-signed cert?
I am following this tutorial. and everything works fine except the certificate. Could you give me an example that I'm a little green on the subject? https://fleetdm.com/docs/deploying/server-installation
openssl req -x509 -newkey rsa:4096 -sha256 -days 3650 -nodes \ -keyout /tmp/server.key -out /tmp/server.cert -subj "/CN=fleetdm" \ -addext "subjectAltName=DNS:"
Thanks for the help. would I be missing something? Or am I making a mistake in the dns by putting the ip?
Make sure that the address you're passing when generating your certificate
Copy code
Is listed as either the CNAME or a
When generating the certificate.
2 cents: If you are using a self-signed cert, when generating the package you need to use the
fleetctl package [...] --insecure
(This is not recommended for production deployments, but given you are using a self-signed certificate you are probably testing Fleet?)
Yeah. It is correct. I am testing with an internal ip. in my lab. sure is that. Now I add the option that you tell me to see how it works. Thank you!