Title
#macos
a

Adam Connor

06/08/2022, 12:04 PM
Hi All, I’ve been creating carnage this afternoon and installed Fleet for the first time (VPS on Ubuntu). Now I have some questions, promise I have read everything I could find but did not found answers- links, docs, anything is welcome-1. Server runs web interface on port 8080 but uses a self signed cert. Safari barfs hard when it sees this. Other products use letsencrypt or a proxy - can we do the same with Fleet? 2. Downloaded and installed the client- it’s unsigned or notarised but this is ok for MDM deployment, or I can sign myself. The bigger issue is that it seems to be installed correctly, but nothing is showing up in my dashboard. How to figure this out? Example- munki and munkireport we can run the client and watch it… Thanks I think that’s all!
d

D4veB3st

06/08/2022, 12:09 PM
ad 2. IMHO the issue is no 1 - you have a self-signed cert on the server so in order for client to connect you need to use a flag
-insecure
when building the .pkg file
a

Adam Connor

06/08/2022, 12:11 PM
thanks @D4veB3st - that does make sense. I might check out this as well to see if I can fix 1. In some ways I was also hoping that someone had a Traefik config, but Traefik is the (sodding) reason I’m here tonight anyway… https://mysteryincorporated.medium.com/nginx-configuration-for-fleetdm-setups-that-want-to-catch-3m-flatties-willem-powerfish-be-proud-7f99f97fdede
a

allister

06/08/2022, 1:01 PM
You’d probably want to head over to #fleet at some point…
a

Adam Connor

06/08/2022, 11:30 PM
thanks @allister will do