https://github.com/osquery/osquery logo
#fleet
Title
# fleet
z

Zachary Case

03/10/2023, 6:22 PM
👋 In the about section of hosts that check-in internally to my fleet I see the internal private ip in the public ip field, I would expect this field to be empty rather than have the private ip address in the public after reading
If the IP retrieved using the above heuristic belongs to a private range, then Fleet will ignore it and will not set the "Public IP address" field for the device.
https://fleetdm.com/docs/deploying/configuration#public-i-ps-of-devices is there a setting that would cause a private ip address to be in the public address field?
l

Lucas Rodriguez

03/10/2023, 6:23 PM
Hi @Zachary Case! What version of Fleet are you using?
z

Zachary Case

03/10/2023, 6:23 PM
v4.27
l

Lucas Rodriguez

03/10/2023, 6:25 PM
That issue was fixed in v4.28.0, upgrading should fix the issue (those docs were added as part of v4.28.0, we'll make sure to add that there).
Copy code
* Only set public IPs on the host.public_ip field and add documentation on how to properly configure the deployment to ingest correct public IPs from enrolled devices.
From changelog 👆
z

Zachary Case

03/10/2023, 6:26 PM
oh wow that’s very timely for me finally looking into this, thanks I’ll get that updated then 😄
l

Lucas Rodriguez

03/10/2023, 6:27 PM
Awesome, let us know if you have any issues with v4.28.0 👍